pic of month     Golden State Discus

Results 1 to 3 of 3

Thread: ecco 2236 trouble

  1. #1
    Silver Member
    Join Date
    May 2014
    Location
    Nassau County, Long Island, NY
    Posts
    483
    iTrader
    1 (100%)

    Default ecco 2236 trouble

    Hi All,
    I have 2 - 2236 Eheim ecco canister filters that I have been running for about 8 years. about a month ago, i started to hear impeller rattling on both of them. i changes the shaft and impeller on one. I cleaned both filter media, brushed the hoses clean. I am still hearing the noise. Has anyone had a similar problem or any suggestions on what I can try?

    Thanks,
    Jim

  2. #2
    Registered Member danotaylor's Avatar
    Join Date
    May 2018
    Location
    Aussie living in Cincy
    Posts
    1,393
    iTrader
    0
    Real Name
    Daniel

    Default Re: ecco 2236 trouble

    There is a small rubber grommet that the shaft slides into. It keeps the shaft stable & centered. Perhaps it has perished on 1 or both ends...you will prob need a flashlight to check the end inside the motor housing.
    Last edited by danotaylor; 09-17-2019 at 04:03 PM.

  3. #3
    Silver Member
    Join Date
    May 2014
    Location
    Nassau County, Long Island, NY
    Posts
    483
    iTrader
    1 (100%)

    Default Re: ecco 2236 trouble

    Quote Originally Posted by danotaylor View Post
    There is a small rubber grommet that the shaft slides into. It keeps the shaft stable & centered. Perhaps it has perished on 1 or both ends...you will prob need a flashlight to check the end inside the motor housing.
    Thanks. I'll check that out

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Cafepress             AquaticSuppliers.com